Die Präsentation wird geladen. Bitte warten

Die Präsentation wird geladen. Bitte warten

Algorithmik Anweisungen (Buch S111) © Katharina Brachmann.

Ähnliche Präsentationen


Präsentation zum Thema: "Algorithmik Anweisungen (Buch S111) © Katharina Brachmann."—  Präsentation transkript:

1 Algorithmik Anweisungen (Buch S111) © Katharina Brachmann

2 Der Robot Karol Karol ist ein Objekt der Klasse ROBOTER. ROBOTER Position Blickrichtung … Schritt() Hinlegen() Aufheben() LinksDrehen() RechtsDrehen() MarkeSetzen() MarkeLöschen() …

3 Anweisungen Du kannst Karol Anweisungen erteilen, damit er sich bewegt oder andere Tätigkeiten ausführt. Lass Karol jetzt folgende Aufgaben erledigen, indem Du ihm geeignete Anweisungen gibst: –Schreibe ein U aus Ziegelsteinen. –Lege eine gerade Reihe von Ziegelsteinen. –Lege eine Zickzackreihe von Ziegelsteinen. –Baue eine Treppe aus Ziegelsteinen.

4 Neue Methoden Du kannst Karol auch neue Anweisungen (Methoden) beibringen. Beispiel: Anweisung FuenfSteineLegen() Hinlegen() Schritt() Hinlegen() Schritt() Hinlegen() Schritt() Hinlegen() Schritt() Hinlegen() *Anweisung Allgemein: Anweisung Methodenname() … *Anweisung

5 Neue Methoden (2) Ab sofort kennt Karol also auch die Methode VierSteineLegen(). Wenn er tatsächlich eine Ziegelviererreihe legen soll, musst Du ihn nur noch dazu auffordern, indem Du die entsprechende Methode aufrufst.

6 Anweisungen (Hefteintrag, Buch S111) Damit Karol bestimmte Tätigkeiten ausführt, muss man ihm Anweisungen geben. Mit anderen Worten: Man schickt Karol eine Botschaft, auf die er mit der Ausführung der gewünschten Methode reagiert. Eine Folge nacheinander auszuführender Anweisungen heißt Sequenz.

7 Aufgaben S114/1 S114/2 S114/3 S114/4 S114/5


Herunterladen ppt "Algorithmik Anweisungen (Buch S111) © Katharina Brachmann."

Ähnliche Präsentationen


Google-Anzeigen