Die Präsentation wird geladen. Bitte warten

Die Präsentation wird geladen. Bitte warten

Algorithmik Bedingte Wiederholung (Buch S119) © Katharina Brachmann.

Ähnliche Präsentationen


Präsentation zum Thema: "Algorithmik Bedingte Wiederholung (Buch S119) © Katharina Brachmann."—  Präsentation transkript:

1 Algorithmik Bedingte Wiederholung (Buch S119) © Katharina Brachmann

2 Die feste Anzahl reicht nicht aus… Karol ist irgendwo in seiner Welt platziert worden und soll von dort aus einen Ziegelweg bis zur Wand legen. Dabei soll er aber nicht an die Wand anstoßen. Ist das mit der Wiederholung mit fester Anzahl möglich? Probiere selbst!

3 Die feste Anzahl reicht nicht aus… (2) Karol muss überprüfen können, ob er die Wand erreicht hat. Dazu verwendet er die Methode IstWand(). Steht er vor einer Wand so liefert diese die Antwort wahr(was soviel wie ja bedeutet). Befindet sich vor ihm keine Wand liefert die Anweisung falsch (was wiederum soviel wie nein bedeutet). Diese Anweisungen gehört zu einer speziellen Klasse von Anweisungen, die Bedingungen genannt werden.

4 Den Aufruf von Methoden, die Fragen mit wahr oder falsch beantworten, nennt man Bedingung. Bedingungen (Hefteintrag, Buch S119)

5 Vordefinierte Bedingungen IstWand(): Liefert wahr, wenn Karol vor einer Wand steht, sonst falsch. IstZiegel(): Liefert wahr, wenn auf dem Feld vor Karol ein Ziegel liegt, sonst falsch. IstMarke(): Liefert wahr, wenn das Feld, auf dem Karol steht, markiert ist, sonst falsch.

6 Wiederholung mit Bedingung Zurück zur Anfangsaufgabe: Karol ist irgendwo in seiner Welt platziert worden und soll von dort aus einen Ziegelweg bis zur Wand legen. Dabei soll er aber nicht an die Wand anstoßen. wiederhole solange NichtIstWand() Hinlegen Schritt *wiederhole

7 Wiederholung mit Bedingung (2) Überprüfe diese Lösung selbst in einem kleinen Programm! Zeichne das Struktogramm!

8 Bedingte Wiederholung (Hefteintrag, Buch S120) Die bedingte Wiederholung wird verwendet, wenn eine Sequenz wiederholt werden soll, solange eine Bedingung wahr ist. wiederhole solange Bedingung Sequenz *wiederhole Die Sequenz innerhalb der Wiederholung wird in Abhängigkeit von der Bedingung gar nicht, einmal oder mehrfach abgearbeitet.

9 Aufgaben S120/1 S121/2 S121/3 S121/4 S121/5 S121/6


Herunterladen ppt "Algorithmik Bedingte Wiederholung (Buch S119) © Katharina Brachmann."

Ähnliche Präsentationen


Google-Anzeigen