Die Präsentation wird geladen. Bitte warten

Die Präsentation wird geladen. Bitte warten

Algorithmik Wiederholung mit fester Anzahl (Buch S 115) © Katharina Brachmann.

Ähnliche Präsentationen


Präsentation zum Thema: "Algorithmik Wiederholung mit fester Anzahl (Buch S 115) © Katharina Brachmann."—  Präsentation transkript:

1 Algorithmik Wiederholung mit fester Anzahl (Buch S 115) © Katharina Brachmann

2 Immer wieder das Gleiche Bei der Anweisung VierSteineLegen() musste Karol viermal hintereinander die Anweisungen Hinlegen() Schritt() ausführen. Für eine derartige Wiederholung mit fester Anzahl kennt Karol eine eigene Anweisung.

3 Immer wieder das Gleiche (2) Beispiel: wiederhole 4 mal Hinlegen() Schritt() *wiederhole TIPP: Schreibe Dein Programm und drücke dann Strg+F. Fällt Dir eine Veränderung auf?

4 Struktogramme wiederhole 6 mal Hinlegen() *wiederhole Schritt() LinksDrehen() wiederhole 6 mal Hinlegen() Schritt() *wiederhole LinksDrehen() wiederhole 6 mal Hinlegen() Schritt() LinksDrehen() *wiederhole wiederhole 6 mal Hinlegen() Schritt() LinksDrehen() wiederhole 6 mal Hinlegen() Schritt() LinksDrehen() wiederhole 6 mal Hinlegen() Schritt() LinksDrehen()

5 Wiederholung mit fester Anzahl (Hefteintrag, Buch S115) Die Wiederholung mit fester Anzahl wird verwendet, wenn eine Sequenz mehrmals ausgeführt werden soll und die Anzahl der Wiederholungen feststeht. Eine Schachtelung von Wiederholungen ist möglich. Das Struktogramm ist eine graphische Darstellung von Programmtexten.

6 Aufgaben S118/1 S118/2 S118/3 S118/4 S118/5 S118/6


Herunterladen ppt "Algorithmik Wiederholung mit fester Anzahl (Buch S 115) © Katharina Brachmann."

Ähnliche Präsentationen


Google-Anzeigen