Die Präsentation wird geladen. Bitte warten

Die Präsentation wird geladen. Bitte warten

Computer-Kurse © 2009 Michaela Behling www.kullererbse.de Formeln in Excel Aufbau und Schreibweise.

Ähnliche Präsentationen


Präsentation zum Thema: "Computer-Kurse © 2009 Michaela Behling www.kullererbse.de Formeln in Excel Aufbau und Schreibweise."—  Präsentation transkript:

1 Computer-Kurse © 2009 Michaela Behling Formeln in Excel Aufbau und Schreibweise

2 Computer-Kurse © 2009 Michaela Behling 1 Bestandteile von Formeln Jede Formel beginnt mit einem Gleichheitszeichen. Grundelemente einer Formel: Eingabewerte und Bezüge Rechenoperationen Funktionen Elemente "produzieren" Werte Ein Eingabewert entspricht sich selbst Bezüge liefern den Wert der zugehörigen Zelle Eine Rechenoperation liefert den Ergebniswert Eine Funktion liefert den Funktionswert Eingabewerte =42 =20,5 =1024 =WAHR Bezüge =A1 =$B7 =$C20 Rechenoperationen =A1+5 =B7/100 =50*2 Funktionen =SUMME(…) MIN(…) ElementliefertWert 42 A2 Wert in A MIN(3;4) 3 Eingabewerte =42 =20,5 =1024 =WAHR Bezüge =A1 =$B7 =$C20 Rechenoperationen =A1+5 =B7/100 =50*2 Funktionen =SUMME(…) MIN(…) ElementliefertWert 42 A2 Wert in A MIN(3;4) 3

3 Computer-Kurse © 2009 Michaela Behling 2 Werte, Werte, Werte … Jedes Grundelement entspricht also einem Wert. Darum kann die simple Addition Wert + Wert in Excel ganz viele verschiedene Formen annehmen: = Addition von Eingabewerten =B4 + (A3/2) Addition eines Bezugswerts mit dem Ergebnis einer Division =MIN(A4:A18) + 10 Addition eines Funktionsergebnisses mit einem Eingabewert =MIN(B3:B20) + SUMME(C1:C24) Addition von Funktionsergebnissen Dieses Prinzip gilt überall, wo Excel einen Wert erwartet. (in Rechenoperationen, bei Funktionsargumenten, …)

4 Computer-Kurse © 2009 Michaela Behling 3 Funktionsargumente Einige Funktionen kommen ganz ohne Argumente aus: ZUFALLSZAHL() PI() ZEILE() Mehrere Funktionsargumente werden jeweils durch ein Semikolon voneinander getrennt. SUMME( A1 ; B4 ; C7 ) MIN( C15 ; 102 ; $A4 ) Ein Funktionsargument kann optional sein, d. h. man kann es beim Aufruf der Funktion auch weglassen. ZEILE() oder ZEILE( A4 ) Excel unterstützt die Eingabe einer Funktion durch ein Quick Info. Optionale Parameter werden in [Klammern] angezeigt. Fettdruck signalisiert das aktuelle Argument.

5 Computer-Kurse © 2009 Michaela Behling 4 Prüfungen Eine Prüfung oder Bedingung liefert einen Wahrheitswert. WAHR bedeutet "stimmt" (entspricht dem Wert 1) FALSCH bedeutet "stimmt nicht" (entspricht dem Wert 0) Mit Vergleichsoperatoren lassen sich Bedingungen formulieren: A1 = B1Prüft, ob zwei Werte gleich sind A1 <> B1Prüft, ob zwei Werte ungleich sind A1 < B1Prüft, ob ein Wert kleiner ist. A1 <= B1Prüft, ob ein Wert kleiner oder gleich ist. A1 > B1Prüft, ob ein Wert größer ist. A1 >= B1Prüft, ob ein Wert größer oder gleich ist. Mehrere Prüfungen können mit Hilfe der Funktionen UND und ODER angegeben werden.

6 Computer-Kurse © 2009 Michaela Behling 5 Wenn-Funktion Wenn( Bedingung ; Dann ; Sonst ) Prüfungsbeispiele A4 > 20 MIN(A2:B10) <= MAX(C5:C8) UND( A5 E20 ) ODER( A1=A2 ; MIN( A1:A2 )=0 ) C4 = WAHR REST( ZEILE()/2 ) = 0 NICHT( A4=0 ) A4 <> 0 Beispiele für Dann-/Sonstwerte "Achtung: Lagerbestand niedrig" SUMME( B2:B24 ) A4 + MIN( B1:B10 ) 42 WENN( … ; … ; … ) FALSCH Dann- oder Sonst-Wert können auch weggelassen werden. WENN( A1<10 ; "Achtung" ) WENN( B4=0 ; ; A2/B4 ) Dann- oder Sonst-Wert können auch weggelassen werden. WENN( A1<10 ; "Achtung" ) WENN( B4=0 ; ; A2/B4 )


Herunterladen ppt "Computer-Kurse © 2009 Michaela Behling www.kullererbse.de Formeln in Excel Aufbau und Schreibweise."

Ähnliche Präsentationen


Google-Anzeigen